• Home
  • Product Information
  • Download
  • Technical Specifications
  • Corporate Information
  • Investor Relations
  • Contact Us

Interface Compatibility Information
Ethernet Interface / Intelligent Interface

Compatibility Information of Ethernet Interface (IFBD-HE07/08) and Intelligent Interface (IFBD-HI01X).

Standard Printer Models

The IFBD-HE07/08 Ethernet Cards and the IFBD-HI01X Intelligent Internet Card are supported by the minimum firmware versions listed in the table below.
In addition, the table also lists the minimum Driver/Utility Package necessary to support these interfaces.
Confirm the printer has the minimum required firmware or higher by performing a Self Test. For instructions on executing a Self Test, refer to the printer's Hardware Manual.


・IFBD-HE07/08
Model Name Compatible Printer Firmware Versions Compatible Printer Drivers and Utility Versions
StarPRNT Intelligence Other Printer Driver
FVP10 Ver. 1.3~ Ver. 1.1a~ -
TSP700II Ver. 3.0~ (*1) Ver. 1.1a~ CD Ver. 1.1 (*2)
TSP650 Ver. 3.0~ (*1) Ver. 1.1a~ CD Ver. 1.0 (*2)
TSP650II Ver. 1.0~ Ver. 2.0~ -
TSP800II Ver. 1.2~ Ver. 1.1a~ -
TSP828L Ver. 2.0~ - CD Ver. 3.0
TSP1000 Ver. 3.0~ - Line/Raster Mode
Printer Driver
TUP500 Ver. 3.0~ Ver. 1.4~ CD Ver. 1.0 (*2)
SP700 Ver. 3.0~ (*1) Ver. 1.1a~ CD Ver. 1.1 (*2)
SP500 Ver. 4.0~ (*1) Ver. 1.1a~ Line/Raster Mode
Printer Driver
HSP7000 Ver. 5.0~ - CD Ver. 2.0 (*3)

*1When using the IFBD-HE07/08 Ethernet Interface Card with 2.0 Firmware, please change the Interface Card setting to Multi-Session. It is possible to change MSW for the printer, after changed to Multi-Session. This can be changed via StarPRNT Intelligence Configuration Utility.

*2The Printer Setting feature is only available through the StarPRNT Intelligence Configuration Utility. It is recommended to ensure this Utility is installed.


・IFBD-HI01X/02X
Supported Printers
Interface Board Model Model Name Compatible Printer Firmware Versions IFBD-HI01X/02X
Boot Version Main Version Firmware Version
IFBD-HI01X TSP650II Ver. 1.0~ Ver. 1.0~ Ver. 1.1~
TSP700II Ver. 2.0~ Ver. 3.0~ Ver. 1.2~
TSP800II Ver. 1.0~ Ver. 1.2~ Ver. 1.2~
IFBD-HI02X SP700 Ver. 2.0~ Ver. 3.0~ Ver. 1.2~

Supported Drivers
Driver StarPRNT Intelligence CD CUPS Driver (Web Release) JavaPOS Driver
(Web Release)
Printer Driver OPOS StarIO Linux Mac
Version Ver. 2.0~ (*3) Ver. 1.13.2~ (*1) Ver. 1.2.2~ Ver. 3.1.1~ (*2) Ver. 3.1.1~ (*2) Ver. 1.9.13~

*1 : OPOS driver with USB is supported from HI01X/02X firmware version 1.2.

*2 : To use CUPS driver, LPR must be set Enable from WebUI. (Default is Disable)
To use LPR, 9100 port also must be set Enable.

*3 : When use PSA Logo Store tool with TSP650II,
please “Reload” Logo again if it is failed to “Reload” the registered Logo from the printer.



TUP500 Configuration Utility Patch Program

This patch remedies functionality between the TUP500 Configuration Utility and IFBD-HE07 Ethernet Card.

Printer : TUP500
Use condition:
  • IFBD-HE07 use
  • Star Printer Configuration Utility use

For information and specifications about this patch, refer to the "Readme_en.txt" file in the download package.

Note
The Virtual Serial Port in ESC/POS Mode is not supported after applying the patch.
TUP500 Configuration Utility Patch Program
ZIP tup500_config_valueadd_update_for_he07_20100709.zip (1.54 MB)


HSP7000 Configuration Utility Patch Program

This patch remedies functionality between the HSP7000 Configuration Utility and IFBD-HE08 Ethernet Card.

Printer : HSP7000
Use condition:
  • IFBD-HE08 use
  • Star Printer Configuration Utility use

For information and specifications about this patch, refer to the "Readme_en.txt" file in the download package.

Note
The Virtual Serial Port in ESC/POS Mode is not supported after applying the patch.
HSP7000 Configuration Utility Patch Program
ZIP hsp7000_config_valueadd_update_for_he08_20100709.zip (1.72 MB)

Visual Card Reader/Writer Models

The IFBD-HE07 Ethernet Card is supported by the minimum firmware versions listed in the table below.
In addition, the table also lists the minimum OCX Driver Package necessary to support this interface.
Confirm the card reader writer has the minimum required firmware or higher by performing a Self Test. For instructions on executing a Self Test, refer to the card reader writer's User's Manual.
The IFBD-HI01X Intelligent interface is not supported by visual card reader/writers.


・IFBD-HE07
Model Name Compatible Card Reader/Writer Firmware Versions Compatible OCX Driver Version
TCP300II Ver. 3.0 Ver. 1.9.0 (*1)
TCP400 Ver. 3.0 Ver. 1.9.0 (*1)

*1Enable multi-session in the Ethernet Utility: System Configuration - #9100 Multi Session -> Enable For details, refer to the separate IFBD-HE07/08 Specification Manual under "Appendix 4.3.2 Card Reader/Writer".

If the firmware and the OCX Driver of the card reader writer is lower than the compatible version listed, contact your dealer for update assistance.

(Questions & Inquiries)
Thank you for using Star Micronics products.
Contact Us

PAGE TOP